package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)((?:[a-z]+\.{0,1}\s*)+)(§{0,2})\s+(\d+)`)
var str = `Guidelines on International Protection: Membership in a “Particular Social Group” Within the Context of Article 1A(2) of the 1951 Convention and/or its 1967 Protocol Relating to the Status of Refugees (UNHCR Guidelines), U.N. Doc. HCR/GIP/02/02 (May 7, 2002).......................................................................23`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}