re = /((?:[a-z]+\.{0,1}\s*)+)(§{0,2})\s+(\d+)/mi
str = 'Guidelines on International Protection: Membership in a “Particular Social Group” Within the Context of Article 1A(2) of the 1951 Convention and/or its 1967 Protocol Relating to the Status of Refugees (UNHCR Guidelines), U.N. Doc. HCR/GIP/02/02 (May 7, 2002).......................................................................23'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end