# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\d)\.|\.(?!\d)/-/gm;t' <<< ".a.b.1.2."