const regex = /(?<!\d)\.|\.(?!\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d)\\.|\\.(?!\\d)', 'gm')
const str = `.a.b.1.2.`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);