package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(alzheimers|baldness|blood pressure|obese)`)
var str = `baldness`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}