$re = '/(?i)(alzheimers|baldness|blood pressure|obese)/';
$str = 'baldness';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);