using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[a-z0-9-]{32,36}$)[a-z0-9]+(?:-[a-z0-9]+){0,4}+$";
string input = @"d3bd55bf-062f-473b-9417-935f62c4c98a
d3bd55bf062f473b9417935f62c4c98a
d3bd-55bf062f473b9417935f62c4c98a
d3bd55-bf06-2f473b9417-935f62c4c98a
d3bd55bf-062f-473b-9417-935f62c4c9-a";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}