use strict;
my $str = 'd3bd55bf-062f-473b-9417-935f62c4c98a
d3bd55bf062f473b9417935f62c4c98a
d3bd-55bf062f473b9417935f62c4c98a
d3bd55-bf06-2f473b9417-935f62c4c98a
d3bd55bf-062f-473b-9417-935f62c4c9-a';
my $regex = qr/^(?=[a-z0-9-]{32,36}$)[a-z0-9]+(?:-[a-z0-9]+){0,4}+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}