const regex = /^\s*(.*\S)\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(.*\\S)\\s*$', 'gm')
const str = ` xx `;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);