use strict;
my $str = ' xx ';
my $regex = qr/^\s*(.*\S)\s*$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";