$re = '/^(.*?)\/(?<mnemonic>.{2,8}?)_(?<isbn>\d{13})_(?<primaryId>.+?)_(?<secondaryId>(\d{1,2}|x)p)(?:_r(?<revisionNumber>\d+))?\.(?<extension>indd|qxp|qxd)$/m';
$str = 'Obam_9781524763138_all_7p_r3 Folder/ObamObamObam_9781524763138_all_0p_r3.indd
Obam_9781524763138_all_7p_r3 Folder/Ob_9781524763138_all_0p_r3.indd
Obam_9781524763138_all_7p_r3 Folder/Obam_9781524763138_all_0p_r3.indd
Obam_9781524763138_all_7p_r3 Folder/Obam_9781524763138_all_77p_r3.indd
Obam_9781524763138_all_7p_r3 Folder/Obam_9781524763138_all_p_r3.indd
Obam_9781524763138_all_7p_r3 Folder/Obam_9781524763138_all_xp_r3.indd
Obam_9781524763138_all_7p_r3 Folder/Obam_9781524763138_all_77p_r3.qxp';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);