package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[\\s]*)?<|tool▁call▁end|>`)
var str = `<|tool▁calls▁begin|><|tool▁call▁begin|>get_time<|tool▁sep|>{"city": "Tokyo"}<|tool▁call▁end|><|tool▁calls▁end|>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}