re = /(?:[\\s]*)?<|tool▁call▁end|>/m
str = '<|tool▁calls▁begin|><|tool▁call▁begin|>get_time<|tool▁sep|>{"city": "Tokyo"}<|tool▁call▁end|><|tool▁calls▁end|>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end