re = /CL\d+__((?:(?!__).)+)__/m
str = '20260317_104524__CL2418942__SOC_PM_DF_CSTATE_REGR__df_cstate_regr__df_umc_nbio_hubs_pcie_msub_\\_.xml
... and I wa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end