#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w(?=,[^,\n]*$)"
Local $sString = "0, 2, 3" & @CRLF & _
"1, 3, 6, 8" & @CRLF & _
"8, 4" & @CRLF & _
"9, 3, 5, 3, 7" & @CRLF & _
"a, b, c, d"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")