$re = '/\w(?=,[^,\n]*$)/m';
$str = '0, 2, 3
1, 3, 6, 8
8, 4
9, 3, 5, 3, 7
a, b, c, d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);