$re = '/[a-zA-Z0-9_+;-]+(?:\\\\,[a-zA-Z0-9_+;-]+)*/m';
$str = 'foo-bar=369,337,234,123
foo-bar=369\\,337\\,234,123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);