re = /[a-zA-Z0-9_+;-]+(?:\\,[a-zA-Z0-9_+;-]+)*/m
str = 'foo-bar=369,337,234,123
foo-bar=369\\,337\\,234,123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end