const regex = /^0+(?!$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0+(?!$)', 'gm')
const str = `005
0AB
000
0`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);