$re = '/^0+(?!$)/m';
$str = '005
0AB
000
0';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;