using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^)|^slug:\h*)[^\r\náé]*\K(?:(á)|é)";
string input = @"slug: bláh-téxt-hello-write-sométhing-ábout-arrow";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}