$re = '/(?:\G(?!^)|^slug:\h*)[^\r\náé]*\K(?:(á)|é)/m';
$str = 'slug: bláh-téxt-hello-write-sométhing-ábout-arrow';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);