import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?xi)^( (DE)?[0-9]{9}|)$";
final String string = "ATU99999999\n"
+ "BE0999999999\n"
+ "BG999999999\n"
+ "HR12345678901\n"
+ "CY99999999L\n"
+ "CZ12345678\n"
+ "DK99999999\n"
+ "EE123456789\n"
+ "FI99999999\n"
+ "FRXX999999999\n"
+ "DE999999999\n"
+ "EL123456789\n"
+ "HU12345678\n"
+ "IE1S23456L\n"
+ "IE1234567T\n"
+ "IE1234567TW\n"
+ "IE1234567FA\n"
+ "ESA12345678\n"
+ "ESZ1234567E\n"
+ "DE813992525";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}