import re
regex = re.compile(r"^Subject:\s*([^=].*)\s*([^=].*)")
test_str = ("Subject:\n"
" =?iso-8859-1?Q?EXPO._SOBRE_SISTEMA_NACIONAL_PREVENCI=D3N_Y_RESPUESTA_ANTE?=\n"
" =?iso-8859-1?Q?_DESASTRES_(SINAPRED).?=\n"
"Thread-Topic:\n"
" =?iso-8859-1?Q?EXPO._SOBRE_SISTEMA_NACIONAL_PREVENCI=D3N_Y_RESPUESTA_ANTE?=\n"
" =?iso-8859-1?Q?_DESASTRES_(SINAPRED).?=\n"
"Thread-Index: AdhhgFXp/SYnL4sVS92k+mSyJTsLqgAAClow")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")