import Foundation
let pattern = #"^Subject:\s*([^=].*)\s*([^=].*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Subject:
=?iso-8859-1?Q?EXPO._SOBRE_SISTEMA_NACIONAL_PREVENCI=D3N_Y_RESPUESTA_ANTE?=
=?iso-8859-1?Q?_DESASTRES_(SINAPRED).?=
Thread-Topic:
=?iso-8859-1?Q?EXPO._SOBRE_SISTEMA_NACIONAL_PREVENCI=D3N_Y_RESPUESTA_ANTE?=
=?iso-8859-1?Q?_DESASTRES_(SINAPRED).?=
Thread-Index: AdhhgFXp/SYnL4sVS92k+mSyJTsLqgAAClow
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}