const regex = /(?P<shortcode>(?:(?:\[))(?P<name>[\w\-]{3,})(?:\s(?P<attrs>[\w\d,\s=\"\'\-\+\#\%\!\~\`\&\.\s\:\/\?\|]+))?(?:\])(?:(?P<content>[\w\d\,\!\@\#\$\%\^\&\*\(\\\\)\s\=\"\'\-\+\&\.\s\:\/\?\|\<\>]+)(?:\[\/[\w\-\_]+\]))?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<shortcode>(?:(?:\\[))(?P<name>[\\w\\-]{3,})(?:\\s(?P<attrs>[\\w\\d,\\s=\\"\\\'\\-\\+\\#\\%\\!\\~\\`\\&\\.\\s\\:\\\/\\?\\|]+))?(?:\\])(?:(?P<content>[\\w\\d\\,\\!\\@\\#\\$\\%\\^\\&\\*\\(\\\\\\\\)\\s\\=\\"\\\'\\-\\+\\&\\.\\s\\:\\\/\\?\\|\\<\\>]+)(?:\\[\\\/[\\w\\-\\_]+\\]))?)', 'gm')
const str = `[attribute name="vid-drevesiny" text_before="(" text_after=")"] [attribute name="vid-drevesiny"] `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}