re = /(?P<shortcode>(?:(?:\[))(?P<name>[\w\-]{3,})(?:\s(?P<attrs>[\w\d,\s=\"\'\-\+\#\%\!\~\`\&\.\s\:\/\?\|]+))?(?:\])(?:(?P<content>[\w\d\,\!\@\#\$\%\^\&\*\(\\\\)\s\=\"\'\-\+\&\.\s\:\/\?\|\<\>]+)(?:\[\/[\w\-\_]+\]))?)/m
str = '[attribute name="vid-drevesiny" text_before="(" text_after=")"] [attribute name="vid-drevesiny"] '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end