package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)news\/[a-z0-9_-]+\/[0-9]+$`)
var str = `news/news_url
news/page/30`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}