package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(master|develop){1}$|^(feature|bugfix|hotfix|chore|experiment)\/([\w-]+?)(\/\d+)?$`)
var str = `feature/add-user-controller/45`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}