re = /^(master|develop){1}$|^(feature|bugfix|hotfix|chore|experiment)\/([\w-]+?)(\/\d+)?$/m
str = 'feature/add-user-controller/45'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end