// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\d+px").unwrap();
let string = "{\"background\":\"linear-gradient(225deg,rgba(255, 255, 255, 0.36) 0%,rgba(255, 255, 255, 0.8) 100%)\",\"boxShadow\":\"0 12px 12px -3px rgba(0, 0, 0, 0.08),0 -8px 14px 0 rgba(255, 255, 255, 0.76),inset 0 0 1px 0 rgba(255, 255, 255, 1),inset 0 2px 0 0 rgba(255, 255, 255, 1)\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}