$re = '/#(\w+)\s/';
$str = 'john#456 18 mai 2017 11:01';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);