$re = '/^(?![@=+*-])(?![\s\S]*[<>])[\s\S]*$/';
$str = 'test jdjie
efkwjwijg';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);