$re = '/^item\d+\s+(\d+)(?:-|\s+minus)\s*(\d+)/m';
$str = 'item1 199-30, 1/1/2021
item2 29 minus 5, 1/1/2021';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);