re = /^item\d+\s+(\d+)(?:-|\s+minus)\s*(\d+)/m
str = 'item1 199-30, 1/1/2021
item2 29 minus 5, 1/1/2021'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end