using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^@\s]+@[^\s]+) <(?!\1)[^@\s]+@[^\s]+>";
string input = @"Bob Jones <bob@example>
bob@example.com <susie@domain.com>
";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}