$re = '/^([^@\s]+@[^\s]+) <(?!\1)[^@\s]+@[^\s]+>/m';
$str = 'Bob Jones <bob@example>
bob@example.com <susie@domain.com>
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);