package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^http:\\www[.]regonal[.]sicolive[.]com\CGI-BIN\[0-9A-Za-z][0-9A-Za-z_.-]*[.](cgi|pl)$`)
var str = `TODAY+12D-1M+3Y
TODAY-123D-1D-3Y
TODAY
TODAY+1D6
TODAY+12D-1D+3Y+3D
TODAY+12X`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}