import re
regex = re.compile(r"^http:\\www[.]regonal[.]sicolive[.]com\CGI-BIN\[0-9A-Za-z][0-9A-Za-z_.-]*[.](cgi|pl)$", flags=re.MULTILINE)
test_str = ("TODAY+12D-1M+3Y\n"
"TODAY-123D-1D-3Y\n"
"TODAY\n\n"
"TODAY+1D6\n"
"TODAY+12D-1D+3Y+3D\n"
"TODAY+12X")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")