re = /classList={{([^}]+)}}/
str = 'classList={{ "bg-white": true, "px-2": false }}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end