using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^library\((.*)\)";
string input = @"library(ggplot2)
library(ggplot2, stringr)
library(""ggplot2"")
library(""ggplot2"", ""yarrr"")
# library(neotoma)
require(stringr)
#' @import fields
#' @importFrom neotoma compile_taxa
neotoma::get_dataset()";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}