import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^library\\((.*)\\)";
final String string = "library(ggplot2)\n"
+ "library(ggplot2, stringr)\n"
+ "library(\"ggplot2\")\n"
+ "library(\"ggplot2\", \"yarrr\")\n"
+ "# library(neotoma)\n"
+ "require(stringr)\n"
+ "#' @import fields\n"
+ "#' @importFrom neotoma compile_taxa\n"
+ "neotoma::get_dataset()";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}