package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:Accident Only Hospital (?:500 - Basic|750 - Basic)|B(?:asic (?:Accident Only Hospital \$(?:500 Excess|750 Excess)|Hospital Cover with \$(?:250 Excess|500 Excess)|Plus Starter Hospital \$(?:500 Excess|750 Excess))|ASIC HOSPITAL COVER|ronze Plus Simple Hospital \$(?:250 Excess|500 Excess|750 Excess)|udget (?:Family Hospital (?:Cover with \$(?:250 Excess|500 Excess)|\$750 Excess)|Hospital (?:with \$(?:1000 Excess(?: and Ambulance Levy)?|250 Excess(?: and Ambulance Levy)?|500 Excess(?: and Ambulance Levy)?)|\$750 Excess - Bronze Plus)))|Established Family Hospital Cover with \$(?:250 Excess|500 Excess|750 Excess)|G(?:old Complete Hospital \$(?:500 Excess|750 Excess)|rowing Family Hospital Cover with \$(?:250 Excess|500 Excess))|Prime Plus with (?:Nil Excess Hospital|\$(?:250 Excess Hospital|500 Excess Hospital))|Si(?:mple Start Hospital Cover|lver Plus (?:Advanced Hospital \$(?:250 Excess|500 Excess|750 Excess)|Essential Hospital \$(?:250 Excess|500 Excess)))|Top Hospital (?:with Pregnancy(?: (?:- Gold|\$(?:250 Excess(?: - Gold)?|500 Excess(?: - Gold)?|750 Excess(?: - Gold)?)))?|Cover no Pregnancy(?: with \$(?:250 Excess|500 Excess))?)))$`)
var str = `Accident Only Hospital 750 - Basic
Accident Only Hospital 500 - Basic
Basic Accident Only Hospital $500 Excess
Basic Accident Only Hospital $750 Excess
Basic Hospital Cover with $250 Excess
Basic Hospital Cover with $500 Excess
BASIC HOSPITAL COVER
Basic Plus Starter Hospital $500 Excess
Basic Plus Starter Hospital $750 Excess
Bronze Plus Simple Hospital $250 Excess
Bronze Plus Simple Hospital $500 Excess
Bronze Plus Simple Hospital $750 Excess
Budget Family Hospital Cover with $250 Excess
Budget Family Hospital Cover with $500 Excess
Budget Family Hospital $750 Excess
Budget Hospital with $500 Excess and Ambulance Levy
Budget Hospital with $500 Excess
Budget Hospital with $250 Excess and Ambulance Levy
Budget Hospital with $250 Excess
Budget Hospital with $1000 Excess and Ambulance Levy
Budget Hospital with $1000 Excess
Budget Hospital $750 Excess - Bronze Plus
Established Family Hospital Cover with $250 Excess
Established Family Hospital Cover with $500 Excess
Established Family Hospital Cover with $750 Excess
Gold Complete Hospital $500 Excess
Gold Complete Hospital $750 Excess
Growing Family Hospital Cover with $250 Excess
Growing Family Hospital Cover with $500 Excess
Prime Plus with Nil Excess Hospital
Prime Plus with $250 Excess Hospital
Prime Plus with $500 Excess Hospital
Simple Start Hospital Cover
Silver Plus Advanced Hospital $250 Excess
Silver Plus Advanced Hospital $500 Excess
Silver Plus Advanced Hospital $750 Excess
Silver Plus Essential Hospital $250 Excess
Silver Plus Essential Hospital $500 Excess
Silver Plus Essential Hospital $500 Excess
Top Hospital with Pregnancy
Top Hospital with Pregnancy - Gold
Top Hospital with Pregnancy $250 Excess
Top Hospital with Pregnancy $250 Excess - Gold
Top Hospital with Pregnancy $500 Excess
Top Hospital with Pregnancy $500 Excess - Gold
Top Hospital with Pregnancy $750 Excess
Top Hospital with Pregnancy $750 Excess - Gold
Top Hospital Cover no Pregnancy
Top Hospital Cover no Pregnancy with $250 Excess
Top Hospital Cover no Pregnancy with $500 Excess`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}