import re
regex = re.compile(r"^(?:(?:Accident Only Hospital (?:500 - Basic|750 - Basic)|B(?:asic (?:Accident Only Hospital \$(?:500 Excess|750 Excess)|Hospital Cover with \$(?:250 Excess|500 Excess)|Plus Starter Hospital \$(?:500 Excess|750 Excess))|ASIC HOSPITAL COVER|ronze Plus Simple Hospital \$(?:250 Excess|500 Excess|750 Excess)|udget (?:Family Hospital (?:Cover with \$(?:250 Excess|500 Excess)|\$750 Excess)|Hospital (?:with \$(?:1000 Excess(?: and Ambulance Levy)?|250 Excess(?: and Ambulance Levy)?|500 Excess(?: and Ambulance Levy)?)|\$750 Excess - Bronze Plus)))|Established Family Hospital Cover with \$(?:250 Excess|500 Excess|750 Excess)|G(?:old Complete Hospital \$(?:500 Excess|750 Excess)|rowing Family Hospital Cover with \$(?:250 Excess|500 Excess))|Prime Plus with (?:Nil Excess Hospital|\$(?:250 Excess Hospital|500 Excess Hospital))|Si(?:mple Start Hospital Cover|lver Plus (?:Advanced Hospital \$(?:250 Excess|500 Excess|750 Excess)|Essential Hospital \$(?:250 Excess|500 Excess)))|Top Hospital (?:with Pregnancy(?: (?:- Gold|\$(?:250 Excess(?: - Gold)?|500 Excess(?: - Gold)?|750 Excess(?: - Gold)?)))?|Cover no Pregnancy(?: with \$(?:250 Excess|500 Excess))?)))$", flags=re.MULTILINE)
test_str = ("Accident Only Hospital 750 - Basic\n"
"Accident Only Hospital 500 - Basic\n"
"Basic Accident Only Hospital $500 Excess\n"
"Basic Accident Only Hospital $750 Excess\n"
"Basic Hospital Cover with $250 Excess\n"
"Basic Hospital Cover with $500 Excess\n"
"BASIC HOSPITAL COVER\n"
"Basic Plus Starter Hospital $500 Excess\n"
"Basic Plus Starter Hospital $750 Excess\n"
"Bronze Plus Simple Hospital $250 Excess\n"
"Bronze Plus Simple Hospital $500 Excess\n"
"Bronze Plus Simple Hospital $750 Excess\n"
"Budget Family Hospital Cover with $250 Excess\n"
"Budget Family Hospital Cover with $500 Excess\n"
"Budget Family Hospital $750 Excess\n"
"Budget Hospital with $500 Excess and Ambulance Levy\n"
"Budget Hospital with $500 Excess\n"
"Budget Hospital with $250 Excess and Ambulance Levy\n"
"Budget Hospital with $250 Excess\n"
"Budget Hospital with $1000 Excess and Ambulance Levy\n"
"Budget Hospital with $1000 Excess\n"
"Budget Hospital $750 Excess - Bronze Plus\n"
"Established Family Hospital Cover with $250 Excess\n"
"Established Family Hospital Cover with $500 Excess\n"
"Established Family Hospital Cover with $750 Excess\n"
"Gold Complete Hospital $500 Excess\n"
"Gold Complete Hospital $750 Excess\n"
"Growing Family Hospital Cover with $250 Excess\n"
"Growing Family Hospital Cover with $500 Excess\n"
"Prime Plus with Nil Excess Hospital\n"
"Prime Plus with $250 Excess Hospital\n"
"Prime Plus with $500 Excess Hospital\n"
"Simple Start Hospital Cover\n"
"Silver Plus Advanced Hospital $250 Excess\n"
"Silver Plus Advanced Hospital $500 Excess\n"
"Silver Plus Advanced Hospital $750 Excess\n"
"Silver Plus Essential Hospital $250 Excess\n"
"Silver Plus Essential Hospital $500 Excess\n"
"Silver Plus Essential Hospital $500 Excess\n"
"Top Hospital with Pregnancy\n"
"Top Hospital with Pregnancy - Gold\n"
"Top Hospital with Pregnancy $250 Excess\n"
"Top Hospital with Pregnancy $250 Excess - Gold\n"
"Top Hospital with Pregnancy $500 Excess\n"
"Top Hospital with Pregnancy $500 Excess - Gold\n"
"Top Hospital with Pregnancy $750 Excess\n"
"Top Hospital with Pregnancy $750 Excess - Gold\n"
"Top Hospital Cover no Pregnancy\n"
"Top Hospital Cover no Pregnancy with $250 Excess\n"
"Top Hospital Cover no Pregnancy with $500 Excess")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")