const regex = /\$status\['[^']+'\][^'"]*(?:'\K(?:[^']|'')+|"\K[^"]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$status\\[\'[^\']+\'\\][^\'"]*(?:\'\\K(?:[^\']|\'\')+|"\\K[^"]+)', 'gm')
const str = `\$status['Совершенно_новое'] = 'Brand_new<<'' New''>>New'
\$status['Совершенно_новое'] = 'Brand_new<br>New'
\$status['2'] = "Brand_new<<' New'>>New" `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}