re = /\$status\['[^']+'\][^'"]*(?:'\K(?:[^']|'')+|"\K[^"]+)/m
str = '$status[\'Совершенно_новое\'] = \'Brand_new<<\'\' New\'\'>>New\'
$status[\'Сове ршенно_новое\'] = \'Brand_new<br>New\'
$status[\'2\'] = "Brand_new<<\' New\'>>New" '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end