using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(youtu.*be.*)\/(watch\?v=|embed\/|v|shorts|)(.*?((?=[&#?])))";
string substitution = @"<iframe width=""100%"" src=""https://www.youtube.com/embed/$3"" frameborder=""0"" allowfullscreen></iframe>";
string input = @"<p>http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index <br><br>https://youtube.com/shorts/0dPkkQeRwTI</p><h2>Para</h2>
<p>http://www.youtube.com/user/IngridMichaelsonVEVO#p/a/u/1/QdK8U-VIH_o</p><p>Para</p>
<p>http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0</p><p>Para</p>
<p><br>http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s</p><p>Para</p>
<p>Check out my youtube video: http://www.youtube.com/embed/0zM3nApSvMg?rel=0</p><p>Para</p>
<p>http://www.youtube.com/watch?v=0zM3nApSvMg</p><p>Para</p>
<p><br>http://youtu.be/0zM3nApSvMg</p><p>Para</p>
<div>https://youtube.com/shorts/0dPkkQeRwTI?feature=share</div>
<p>https://youtube.com/shorts/0dPkkQeRwTI</p><p>Para</p>
<p>https://www.youtube.com/watch?v=0dPkkQeRwTI&ab_channel=RelaxedChan</p><p>Para</p>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}