$re = '/(^|\B)(#(?![0-9_]+\b)([a-zA-Z0-9_]{1,30})(\b|\r))+/m';
$str = '#hey#there#buddy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);