re = /(^|\B)(#(?![0-9_]+\b)([a-zA-Z0-9_]{1,30})(\b|\r))+/m
str = '#hey#there#buddy'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end