import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!vk\\.com)[a-z0-9\\-\\_]{2,64}\\.[a-z]{2,6}";
final String string = "zzz.com\n"
+ "aaa.net\n"
+ "vk.com\n"
+ "blabla.bla\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}